 文字輪郭 text_outline_dxf

文字の輪郭と中心線で，ＤＸＦファイルを直線と円と円弧で作成します。(VC++ V6作成)
作成できる文字は半角文字のみです。
小数点以下9桁の為に，折れや離れや交差します。エラーメッセージ以降の文字は作成しません。
エラーメッセージの線幅は，記入した線幅も含む為に，記入した値により変わります。
エラーメッセージがマイナスの時は，線幅を減らしても変わりますが， 文字幅や文字高の変更も必要かも。
等幅フォントで，レイヤ１の実線で，枠と中心線は水色で，輪郭は紫です。
文字幅と文字高に余白は有りません。 文字間隔は，文字幅の２０％と思われます。
行間隔は，文字間隔と同じと思われます。 行間隔は，文字高の５０％が見易いと思われます。
線幅は，文字幅か文字高の小さい方の１５％と思われます。 線幅は，文字幅か文字高未満です。

参照ボタンで，作成したいＤＸＦファイルを選択して下さい。
文字幅と文字高と線幅と 文字間隔と行間隔と使用可能文字は，下図を参照して下さい。
文字に，作成したい輪郭の文字を記入して下さい。
作成で，ＤＸＦファイルを作成します。
枠幅に，文字範囲の横の長さを記入して下さい。
枠高に，文字範囲の縦の高さを記入して下さい。
枠行文字数に，文字範囲での文字のスペースを含んだ一行の最大の文字数を記入して下さい。
枠行数に，文字範囲での改行のみの文字の無い行を含んだ行数を記入して下さい。
枠線幅に，文字範囲での線幅を，文字範囲での 文字幅か文字高のパーセントで記入して下さい。
枠文字間隔に，文字範囲での文字間隔を，文字範囲での 文字幅のパーセントで記入して下さい。
枠行間隔に，文字範囲での行間隔を，文字範囲での 文字高のパーセントで記入して下さい。
枠計算で，記入した枠幅と枠高と 枠行文字数と枠行数と枠線幅と 枠文字間隔と枠行間隔で，文字幅と 文字高と線幅と文字間隔と 行間隔を計算して，文字幅と文字高と 線幅と文字間隔と行間隔に反映します。
文字幅＝枠幅／（枠行文字数＋ 枠行文字数Ｘ枠文字間隔Ｘ０．０１―枠文字間隔Ｘ０．０１）
文字高＝枠高／（枠行数＋ 枠行数Ｘ枠行間隔Ｘ０．０１―枠行間隔Ｘ０．０１）
文字間隔＝文字幅Ｘ枠行間隔Ｘ０．０１
行間隔＝文字高Ｘ枠行間隔Ｘ０．０１
線幅＝文字幅Ｘ枠線幅Ｘ０．０１　か　 線幅＝文字高Ｘ枠線幅Ｘ０．０１　の小さい方に成ります。
終了で，text_outline_dxfを閉じます。
ヘルプで，このヘルプは表示できません。

以下は最大の目安で，文字幅や 文字高や線幅で変わります。
文字のゼロの線幅は，文字幅の４６％未満です。文字のゼロの 線幅は，文字高の５０％未満です。
文字の１の線幅は，文字幅 か文字高の２５％未満です。
文字の２の線幅は，文字幅の５０％未満です。文字の２の 線幅は，文字高の３３％未満です。
文字の３の線幅は，文字幅の５０％未満です。文字の３の 線幅は，文字高の３３％未満です。
文字の４の線幅は，文字幅 か文字高の２５％未満です。
文字の５の線幅は，文字幅の５０％未満です。文字の５の 線幅は，文字高の２３％未満です。
文字の６の線幅は，文字幅の５０％未満です。文字の６の 線幅は，文字高の２３％未満です。
文字の７の線幅は，文字幅の６６％未満です。文字の７の 線幅は，文字高の５２％未満です。
文字の８の線幅は，文字幅の５０％未満です。文字の８の 線幅は，文字高の３３％未満です。
文字の９の線幅は，文字幅の５０％未満です。文字の９の 線幅は，文字高の２３％未満です。
文字のＡの線幅は，文字幅の４０％未満です。文字のＡの 線幅は，文字高の３５％未満です。
文字のＢの線幅は，文字高の４０％超過です。文字のＢの 線幅は，文字高の３３％未満です。
文字のＣの線幅は，文字幅の５０％未満です。文字のＣの 線幅は，文字高の４０％未満です。
文字のＤの線幅は，文字幅の４０％未満です。文字のＤの 線幅は，文字高の５０％未満です。
文字のＥの線幅は，文字幅の６０％未満です。文字のＥの 線幅は，文字高の３３％未満です。
文字のＦの線幅は，文字幅の６０％未満です。文字のＦの 線幅は，文字高の３３％未満です。
文字のＧの線幅は，文字幅の３３％未満です。文字のＧの 線幅は，文字高の２４％未満です。
文字のＨの線幅は，文字幅の５０％未満です。文字のＨの 線幅は，文字高の５０％未満です。
文字のＩの線幅は，文字幅の３０％未満です。文字のＩの 線幅は，文字高の５０％未満です。
文字のＪの線幅は，文字幅の５０％未満です。文字のＪの 線幅は，文字高の５０％未満です。
文字のＫの線幅は，文字幅の５０％未満です。文字のＫの 線幅は，文字高の５０％未満です。
文字のＬの線幅は，文字幅の６６％未満です。文字のＬの 線幅は，文字高の６６％未満です。
文字のＭの線幅は，文字幅の３３％未満です。文字のＭの 線幅は，文字高の６６％未満です。
文字のＮの線幅は，文字幅の５０％未満です。文字のＮの 線幅は，文字高の６６％未満です。
文字のＯの線幅は，文字幅の５０％未満です。文字のＯの 線幅は，文字高の５０％未満です。
文字のＰの線幅は，文字幅の４０％未満です。文字のＰの 線幅は，文字高の３３％未満です。
文字のＱの線幅は，文字幅 か文字高の２５％未満です。
文字のＲの線幅は，文字幅の４３％未満です。文字のＲの 線幅は，文字高の３３％未満です。
文字のＳの線幅は，文字幅の５０％未満です。文字のＳの 線幅は，文字高の２６％未満です。
文字のＴの線幅は，文字幅の５０％未満です。文字のＴの 線幅は，文字高の６６％未満です。
文字のＵの線幅は，文字幅の５０％未満です。文字のＵの 線幅は，文字高の５０％未満です。
文字のＶの線幅は，文字幅の７１％未満です。文字のＶの 線幅は，文字高の１００％未満です。
文字のＷの線幅は，文字幅の５５％未満です。文字のＷの 線幅は，文字高の１００％未満です。
文字のＸの線幅は，文字幅の５８％未満です。文字のＸの 線幅は，文字高の５８％未満です。
文字のＹの線幅は，文字幅の６２％未満です。文字のＹの 線幅は，文字高の６６％未満です。
文字のＺの線幅は，文字幅の６６％未満です。文字のＺの 線幅は，文字高の５０％未満です。
文字の＜の線幅は，文字幅の１００％未満です。文字の＜の線幅は，文字高の７１％未満です。
文字の＞の線幅は，文字幅の１００％未満です。文字の＞の 線幅は，文字高の７１％未満です。
文字の－の線幅は，文字幅の１００％未満です。文字の－の 線幅は，文字高の１００％未満です。
文字の＿の線幅は，文字幅の１００％未満です。文字の＿の 線幅は，文字高の１００％未満です。
文字の｜の線幅は，文字幅の１００％未満です。文字の｜の 線幅は，文字高の１００％未満です。
文字の／の線幅は，文字幅の１００％未満です。文字の／の 線幅は，文字高の１００％未満です。
文字の＋の線幅は，文字幅の５０％未満です。文字の＋の 線幅は，文字高の５０％未満です。
文字の＝の線幅は，文字幅の１００％未満です。文字の＝の 線幅は，文字高の３３％未満です。
文字の点⇒．の線幅は，文字幅の５８％未満です。文字の点の 線幅は，文字高の５８％未満です。文字の点は， 線幅との比率で作成してます。文字の点の中心線の円の直径は線幅の７０％です。
文字のコンマ⇒，の線幅は，文字幅の５０％未満です。文字のコンマの 線幅は，文字高の４０％未満です。文字のコンマは， 線幅との比率で作成してます。文字のコンマの中心線の円の直径は線幅の６０％です。
文字のコロン⇒：の線幅は，文字幅の６２％未満です。文字のコロンの 線幅は，文字高の３１％未満です。文字のコロンの中心線の円の直径は 線幅の６０％です。
文字のセミコロン⇒；の線幅は，文字幅の５０％未満です。文字のセミコロンの 線幅は，文字高の３１％未満です。文字のセミコロンの中心線の円の直径は 線幅の６０％です。
文字のアポストロフィ⇒’の線幅は，文字幅の５０％未満です。文字のアポストロフィの 線幅は，文字高の４０％未満です。文字のアポストロフィは， 線幅との比率で作成してます。。文字のアポストロフィの中心線の円の直径は線幅の６０％です。
文字のダブルクォート⇒”の線幅は，文字幅の２５％未満です。文字のダブルクォートの 線幅は，文字高の４０％未満です。文字のダブルクォートは， 線幅との比率で作成してます。。文字のダブルクォートの中心線の円の直径は線幅の６０％です。
文字のアクサングラーブ⇒‘の線幅は，文字幅の５０％未満です。文字のアクサングラーブの 線幅は，文字高の４０％未満です。文字のアクサングラーブは， 線幅との比率で作成してます。文字のアクサングラーブの中心線の円の直径は線幅の６０％です。
文字の［の線幅は，文字幅の６０％未満です。文字の［の 線幅は，文字高の５０％未満です。
文字の］の線幅は，文字幅の６０％未満です。文字の］の 線幅は，文字高の５０％未満です。
文字の（の線幅は，文字幅の６０％未満です。文字の（の 線幅は，文字高の５０％未満です。
文字の）の線幅は，文字幅の６０％未満です。文字の）の 線幅は，文字高の５０％未満です。
文字の｛の線幅は，文字幅の５０％未満です。文字の｛の 線幅は，文字高の３３％未満です。
文字の｝の線幅は，文字幅の５０％未満です。文字の｝の 線幅は，文字高の３３％未満です。
文字のキャレット⇒＾の線幅は，文字幅の５８％未満です。文字のキャレットの 線幅は，文字高の４１％未満です。
文字のチルダ⇒~の線幅は，文字幅の３３％未満です。文字のチルダの 線幅は，文字高の２３％未満です。
文字の＃の線幅は，文字幅の２６％未満です。文字の＃の 線幅は，文字高の２６％未満です。
文字の％の線幅は，文字幅の２３％未満です。文字の％の 線幅は，文字高の２３％未満です。
文字の！の線幅は，文字幅の６２％未満です。文字の！の 線幅は，文字高の２８％未満です。文字の！の中心線の円の直径は 線幅の６０％です。
文字の＄の線幅は，文字幅の３２％未満です。文字の＄の 線幅は，文字高の２４％未満です。
文字の￥の線幅は，文字幅の５０％未満です。文字の￥の 線幅は，文字高の２７％未満です。
文字の＊の線幅は，文字幅の３５％未満です。文字の＊の 線幅は，文字高の３５％未満です。
文字の＆の線幅は，文字幅の３３％未満です。文字の＆の 線幅は，文字高の２５％未満です。
文字の＠の線幅は，文字幅の２５％未満です。文字の＠の 線幅は，文字高の２５％未満です。
文字の？の線幅は，文字幅の４５％未満です。文字の？の 線幅は，文字高の２３％未満です。文字の？の中心線の円の直径は 線幅の２０％です。
文字のａの線幅は，文字幅の３９％未満です。文字のａの 線幅は，文字高の１６％未満です。
文字のｂの線幅は，文字幅の５０％未満です。文字のｂの 線幅は，文字高の２３％未満です。
文字のｃの線幅は，文字幅の５０％未満です。文字のｃの 線幅は，文字高の３０％未満です。
文字のｄの線幅は，文字幅の５０％未満です。文字のｄの 線幅は，文字高の２３％未満です。
文字のｅの線幅は，文字幅の５０％未満です。文字のｅの 線幅は，文字高の２０％未満です。
文字のｆの線幅は，文字幅の３３％未満です。文字のｆの 線幅は，文字高の３０％未満です。
文字のｇの線幅は，文字幅の５０％未満です。文字のｇの 線幅は，文字高の１６％未満です。
文字のｈの線幅は，文字幅の５０％未満です。文字のｈの 線幅は，文字高の３６％未満です。
文字のｉの線幅は，文字幅の６２％未満です。文字のｉの 線幅は，文字高の２３％未満です。文字のｉの中心線の円の直径は 線幅の６０％です。
文字のｊの線幅は，文字幅の４３％未満です。文字のｊの 線幅は，文字高の２３％未満です。文字のｊの中心線の円の直径は 線幅の６０％です。
文字のｋの線幅は，文字幅の５０％未満です。文字のｋの 線幅は，文字高の４０％未満です。
文字のｌの線幅は，文字幅の４０％未満です。文字のｌの 線幅は，文字高の６６％未満です。
文字のｍの線幅は，文字幅の３３％未満です。文字のｍの 線幅は，文字高の２３％未満です。
文字のｎの線幅は，文字幅の５０％未満です。文字のｎの 線幅は，文字高の２３％未満です。
文字のｏの線幅は，文字幅の５０％未満です。文字のｏの 線幅は，文字高の４０％未満です。
文字のｐの線幅は，文字幅の５０％未満です。文字のｐの 線幅は，文字高の２２％未満です。
文字のｑの線幅は，文字幅の５０％未満です。文字のｑの 線幅は，文字高の２２％未満です。
文字のｒの線幅は，文字幅の５０％未満です。文字のｒの 線幅は，文字高の２２％未満です。
文字のｓの線幅は，文字幅の５０％未満です。文字のｓの 線幅は，文字高の１８％未満です。
文字のｔの線幅は，文字幅の４０％未満です。文字のｔの 線幅は，文字高の２４％未満です。
文字のｕの線幅は，文字幅の５０％未満です。文字のｕの 線幅は，文字高の２３％未満です。
文字のｖの線幅は，文字幅の６１％未満です。文字のｖの 線幅は，文字高の８０％未満です。
文字のｗの線幅は，文字幅の４４％未満です。文字のｗの 線幅は，文字高の８０％未満です。
文字のｘの線幅は，文字幅の５８％未満です。文字のｘの 線幅は，文字高の４９％未満です。
文字のｙの線幅は，文字幅の５８％未満です。文字のｙの 線幅は，文字高の４９％未満です。
文字のｚの線幅は，文字幅の６３％未満です。文字のｚの 線幅は，文字高の４０％未満です。

フリーソフトです。営利目的でなければ，使用や改造等を自由にして下さい。自己責任で使用して下さい。